PDA

View Full Version : Using Starcraft with Wine



Phrostbite
01-25-2009, 01:34 PM
Alright so I am using wine on ubuntu and i got starcraft to work with wine however it is slow. Almost as if I was playing in a online game that had really bad lag. I have google searched looking for answers and so far none of them have helped. Anybody here think they can assist me?

I was not sure if this went here or in the linux area.

applesauce
01-25-2009, 01:47 PM
Don't even bother. Find a Linux version of StarCraft :P



HOWEVER, if you do want to try, it will take time, and it will be buggy.

SOURCE:


To get ipx network support, IPX will have to be enabled in the kernel, and you need some userspace utilities, usually called ipx-utils; and IPX must be started (there should be an initscript).

*ubuntu users can use the commands:

sudo apt-get install ipx; sudo modprobe ipx; sudo ipx_interface add -p eth0 802.2 0x12345678

(change eth0 for the name of your ethernet/wireless card)

The frame type (802.2) needs to be equal for everyone. It is recommended to use ethernet II instead of 802.2. If playing with computers with Windows, make sure their frame type is set to what you have, and not 'automatic'. It may cause issues if you forget it.

if you update the game to 1.15.2 then you can also play using UDP




If the game runs slow on your machine then look at this page (http://wiki.winehq.org/UsefulRegistryKeys)

Use the key "DirectDrawRenderer" and add that to your registry with the value "opengl"; you may also need to add the key "RenderTargetLockMode" with the value "readtex".

(Found under HKEY_CURRENT_USER/Software/Wine/Direct3D using regedit)

If the above trick does not work, or causes your Starcraft to crash on launch:

- Remove the DirectDrawRender registry entry.
- Use your Wine Configuration utility to set Emulate Virtual Desktop to on, resolution 640 x 480.

Phrostbite
01-25-2009, 02:41 PM
Thats on the winhq db page ;). I tried that stuff and it's still laggy. I also don't need to play online since it was a key i found on the internet :)

applesauce
01-25-2009, 04:03 PM
Thats on the winhq db page ;). I tried that stuff and it's still laggy. I also don't need to play online since it was a key i found on the internet :)

Sounds like you are having a gfx driver issue. What kind of graphics card did you install? And is it listed in the Restricted Driver (I think it's called Hardware now though) manager?

Phrostbite
01-25-2009, 04:56 PM
To be honest I have no idea what graphics card is in my laptop. Its a dell inspiron 6000. So whatever came with that. How would I find out whats card I have in this?

EDIT

Ok I feel like an idiot. The drivers were not activated however it still does not work properly. I went through the steps again and still laggy.

Dukath
01-25-2009, 05:18 PM
You have to set DirectDrawRender to opengl, RenderTargetLockMode to readdraw, VideoMemorySize to something.

Try wine-doors for setting up the environment, install some apps, make them work.

And don't run desktop effects.

EDIT: Enable CPU throttling.

Phrostbite
01-25-2009, 05:54 PM
I downloaded wine doors and I seem to be having difficulties. I read around and I still am not sure how this works. I see you can use it to install apps and things like that. It has its own preferances i see, does this take the place of wine or does it add to it? Because if they each have there own preferences then how am i supposed to know which one to edit?